Back to overview
Degraded
EAC Outage
Aug 14 at 06:32pm CDT
Affected services
Rust Origins Server
Rust Rift Server
Resolved
Aug 14 at 07:12pm CDT
It appears that the connection issues have been resolved.
Affected services
Rust Origins Server
Rust Rift Server
Created
Aug 14 at 06:32pm CDT
Players are unable to connect to the Origins and Rift servers due to an outage of EAC.
Affected services
Rust Origins Server
Rust Rift Server