Back to overview
Maintenance

Control Panel Update

Jul 20 at 09:00am CDT  –  Jul 20 at 09:20am CDT
Affected services
Server Panel
Dedicated Server
Rust Origins Server
Rust Rift Server

Resolved
Jul 20 at 09:15am CDT

The maintenance has been completed and servers are currently restarting.

Created
Jul 20 at 09:00am CDT

During this morning's restart we will be updating the control panel used for our game servers. There will be a slightly longer restart due to this.